liuadvance 发表于 2013-11-5 14:34:09

xcode编译osg有如下错误,如何解决,求大神



clang: error: invalid argument '-mmacosx-version-min=10.6' not allowed with '-miphoneos-version-min=4.1'
clang: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later)
clang: error: invalid argument '-mmacosx-version-min=10.6' not allowed with '-miphoneos-version-min=4.1'
clang: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later)
clang: error: invalid argument '-mmacosx-version-min=10.6' not allowed with '-miphoneos-version-min=4.1'
clang: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later)
Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang failed with exit code 1

liuadvance 发表于 2013-11-5 14:45:39

还有个错误:
/OSG/OpenSceneGraph-3.1.6/src/osgDB/FileUtils.cpp:877:18: 'Foundation/Foundation.h' file not found

array 发表于 2013-11-18 10:01:41

(requires OS X 10.7 or later)
页: [1]
查看完整版本: xcode编译osg有如下错误,如何解决,求大神