查看: 1840|回复: 2

xcode编译osg有如下错误,如何解决,求大神

[复制链接]

该用户从未签到

发表于 2013-11-5 14:34:09 | 显示全部楼层 |阅读模式


clang: error: invalid argument '-mmacosx-version-min=10.6' not allowed with '-miphoneos-version-min=4.1'
clang: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later)
clang: error: invalid argument '-mmacosx-version-min=10.6' not allowed with '-miphoneos-version-min=4.1'
clang: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later)
clang: error: invalid argument '-mmacosx-version-min=10.6' not allowed with '-miphoneos-version-min=4.1'
clang: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later)
Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang failed with exit code 1

该用户从未签到

 楼主| 发表于 2013-11-5 14:45:39 | 显示全部楼层
还有个错误:
/OSG/OpenSceneGraph-3.1.6/src/osgDB/FileUtils.cpp:877:18: 'Foundation/Foundation.h' file not found

该用户从未签到

发表于 2013-11-18 10:01:41 | 显示全部楼层
(requires OS X 10.7 or later)
您需要登录后才可以回帖 登录 | 注册

本版积分规则

OSG中国官方论坛-有您OSG在中国才更好

网站简介:osgChina是国内首个三维相关技术开源社区,旨在为国内更多的技术开发人员提供最前沿的技术资讯,为更多的三维从业者提供一个学习、交流的技术平台。

联系我们

  • 工作时间:09:00--18:00
  • 反馈邮箱:1315785073@qq.com
快速回复 返回顶部 返回列表