查看: 21652|回复: 91

OSG3.3.1和osgEarth2.5 VC10编译包(附源码)

[复制链接]

该用户从未签到

发表于 2012-11-4 21:39:56 | 显示全部楼层 |阅读模式
本帖最后由 ago 于 2016-8-22 09:01 编辑

免费osgEarth编辑器SXEarth2.6.0 欢迎下载
下载地址: www.sxsim.com

晟兴三维数字地球SXEarth2_6_3small.jpg
OSG3.3.1和osgEarth2.5 VC10编译包(附源码)

下载地址:
http://pan.baidu.com/s/1hq9Pwzi



2.5新特性:
      1.地形特效:细节纹理等
      2.导航图


OSG3.1.4和osgEarth2.3 VC10编译包

下载地址:
http://pan.baidu.com/share/link?shareid=107009&uk=2801833827

osg3.14和osgEarth2.3源代码地址:
http://pan.baidu.com/share/link?shareid=97964&uk=2801833827
http://pan.baidu.com/share/link?shareid=97963&uk=2801833827



Highlights include:

* iOS 支持
* 实时阴影
* 默认使用Quadtree地形引擎,速度比之前的osgterrain更快,占用内存更少,生成的地形边缘更光滑。
* TFS (Tiled Feature Service) 矢量打包
* Boundary tool for stitched-in site models
* 图像层色彩调整
* New GL/GLES shader generator










该用户从未签到

发表于 2013-9-6 00:41:35 | 显示全部楼层
楼主,新人请教个问题,cmake的时候提示我找不到osgqt,没法build出来工程,能请教下怎么根据osgqt源代码编译出所需的dll和lib么……ps:我是从osg官网下的最新的代码,里面有osgqt,但是make出来的工程里面没有osgqt

该用户从未签到

发表于 2012-11-5 13:42:22 | 显示全部楼层
先顶一下再下载!谢谢楼主!

该用户从未签到

发表于 2012-11-5 14:51:46 | 显示全部楼层
楼主做的?

该用户从未签到

发表于 2012-11-16 10:41:29 | 显示全部楼层
嘿,下载不了,地址无效了。

该用户从未签到

 楼主| 发表于 2012-11-16 18:20:53 来自手机 | 显示全部楼层
chworm 发表于 2012-11-16 10:41
嘿,下载不了,地址无效了。

编译包有bug,暂不提供下载,抱歉了

该用户从未签到

 楼主| 发表于 2012-11-18 12:12:29 | 显示全部楼层
chworm 发表于 2012-11-16 10:41
嘿,下载不了,地址无效了。

现在可以下载了,有问题可以回帖或给我留言

该用户从未签到

发表于 2012-12-26 14:05:14 | 显示全部楼层
谢谢楼主分享,不过运行的时候出现了一个问题
J:\OSG>cd ./bin

J:\OSG\bin>osgearth_controls ../tests/feature_labels.earth  --sky --ocean
[osgEarth]  [GDAL driver] Max Data Level: 3
[osgEarth]  [FeatureModelGraph] Registered FMG 1
[osgEarth]  [FeatureModelGraph] Registered FMG 2
[osgEarth]  [FeatureModelGraph] Registered FMG 3
glLinkProgram "engine_osgterrain:TerrainNode" FAILED
Program "engine_osgterrain:TerrainNode" infolog:
Fragment shader(s) failed to link,  vertex shader(s) failed to link.
ERROR: 0:4: error(#191) Redeclaration of array with size osg_TexCoord
ERROR: error(#273) 1 compilation errors.  No code generated

ERROR: 0:2: error(#191) Redeclaration of array with size osg_TexCoord
ERROR: error(#273) 1 compilation errors.  No code generated

显示的地球是黑色的,没有贴上图,不知道怎么解决呢,请教下各位大神啊!


该用户从未签到

 楼主| 发表于 2012-12-26 20:35:19 | 显示全部楼层
miracletiger 发表于 2012-12-26 14:05
谢谢楼主分享,不过运行的时候出现了一个问题
J:\OSG>cd ./bin

你用的显卡是不是A卡,A卡上我遇到过这个问题,Intel集成显卡和N卡没遇到这个问题

该用户从未签到

发表于 2012-12-28 08:36:59 | 显示全部楼层
是联想Y460是A卡,那这怎么解决呢

该用户从未签到

 楼主| 发表于 2012-12-28 12:22:21 来自手机 | 显示全部楼层
和我的电脑一样y460,切到集显可以用
可能是支持的opengl版本太低了

该用户从未签到

 楼主| 发表于 2012-12-28 12:23:21 来自手机 | 显示全部楼层
miracletiger 发表于 2012-12-28 08:36
是联想Y460是A卡,那这怎么解决呢

和我的电脑一样y460,切到集显可以用
可能是支持的opengl版本太低了

该用户从未签到

 楼主| 发表于 2012-12-28 12:27:35 来自手机 | 显示全部楼层
用新版本的opengl可以获得更高的性能,增加了一些新功能,但老显卡不一定会支持

该用户从未签到

发表于 2012-12-29 20:31:20 | 显示全部楼层
楼主。你的OSG3.1.4 是哪个版本呢,是 OpenSceneGraph-3.0.1吗,我编译的时候遇到了一个问题
错误        45        error C1083: 无法打开包括文件:“osgShadow/ViewDependentShadowMap”: No such file or directory        G:\osgearth\osgearth\src\applications\osgearth_shadow\osgearth_shadow.cpp        34        1        Sample osgearth_shadow
你碰到过吗?

该用户从未签到

发表于 2012-12-30 11:17:36 | 显示全部楼层
错误        2        error LNK2001: 无法解析的外部符号 "public: virtual int __thiscall OGRPolygon::Centroid(class OGRPoint *)const " (?Centroid@OGRPolygon@@UBEHPAVOGRPoint@@@Z)        J:\osgnewset\OpenSceneGraph\vs2010\src\osgPlugins\ogr\ReaderWriterOGR.obj        Plugins ogr
错误        5        error LNK2001: 无法解析的外部符号 "public: virtual int __thiscall OGRPolygon::Centroid(class OGRPoint *)const " (?Centroid@OGRPolygon@@UBEHPAVOGRPoint@@@Z)        J:\osgnewset\OpenSceneGraph\vs2010\src\osgPlugins\ogr\ReaderWriterOGR.obj        Plugins ogr
错误        1        error LNK2001: 无法解析的外部符号 "public: virtual char * __thiscall OGRGeometry::exportToGML(void)const " (?exportToGML@OGRGeometry@@UBEPADXZ)        J:\osgnewset\OpenSceneGraph\vs2010\src\osgPlugins\ogr\ReaderWriterOGR.obj        Plugins ogr
错误        4        error LNK2001: 无法解析的外部符号 "public: virtual char * __thiscall OGRGeometry::exportToGML(void)const " (?exportToGML@OGRGeometry@@UBEPADXZ)        J:\osgnewset\OpenSceneGraph\vs2010\src\osgPlugins\ogr\ReaderWriterOGR.obj        Plugins ogr
错误        3        error LNK1120: 2 个无法解析的外部命令        J:\osgnewset\OpenSceneGraph\vs2010\bin\osgPlugins-3.1.4\osgdb_ogr.dll        Plugins ogr
错误        6        error LNK1120: 2 个无法解析的外部命令        J:\osgnewset\OpenSceneGraph\vs2010\bin\osgPlugins-3.1.4\osgdb_ogrd.dll        Plugins ogr
楼主,我用最新svn下的osg编译出现了这几个错误,你碰到过没呢?

该用户从未签到

发表于 2013-1-3 20:55:30 | 显示全部楼层
顶~版主的这个太好了,初学者的福利,呵呵~

该用户从未签到

 楼主| 发表于 2013-1-6 21:17:42 | 显示全部楼层
csdn 发表于 2013-1-3 20:55
顶~版主的这个太好了,初学者的福利,呵呵~

做编译包,包括里面的可运行案例,就是为了让大家对osgEarth有个快速的认识

该用户从未签到

发表于 2013-1-10 14:48:47 | 显示全部楼层
非常感谢!!

该用户从未签到

发表于 2013-1-27 01:16:16 | 显示全部楼层
谢谢!

该用户从未签到

发表于 2013-2-17 08:11:17 | 显示全部楼层
本帖最后由 ago 于 2013-3-15 09:15 编辑

我是下载的编译包,把OSG和OSGearth重新编译了下,osgEarthd老是链接错误,不知道各位有没发现过? 我的VC2010
正在创建库 F:/osgEarth-2.3/project/lib/Debug/osgEarthd.lib 和对象 F:/osgEarth-2.3/project/lib/Debug/osgEarthd.exp
1>CullingUtils.obj : error LNK2019: 无法解析的外部符号 "__declspec(dllimport) public: class osg::Camera * __thiscall osgUtil::CullVisitor::getCurrentCamera(void)" (__imp_?getCurrentCamera@CullVisitor@osgUtil@@QAEPAVCamera@osg@@XZ),该符号在函数 "public: virtual void __thiscall osgEarth::CullNodeByNormal:perator()(class osg::Node *,class osg::NodeVisitor *)" (??RCullNodeByNormal@osgEarth@@UAEXPAVNode@osg@@PAVNodeVisitor@3@@Z) 中被引用
1>OverlayDecorator.obj : error LNK2001: 无法解析的外部符号 "__declspec(dllimport) public: class osg::Camera * __thiscall osgUtil::CullVisitor::getCurrentCamera(void)" (__imp_?getCurrentCamera@CullVisitor@osgUtil@@QAEPAVCamera@osg@@XZ)

tual void __thiscall osgEarth::SpatialReference::_init(void)" (?_init@SpatialReference@osgEarth@@MAEXXZ) 中被引用
1>F:\osgEarth-2.3\project\lib\Debug\osgEarthd.dll : fatal error LNK1120: 174 个无法解析的外部命令
1>
1>生成失败。
1>
1>已用时间 00:00:56.98
========== 生成: 成功 0 个,失败 1 个,最新 0 个,跳过 0 个 ==========

该用户从未签到

发表于 2013-2-18 08:13:25 | 显示全部楼层
问题解决了,可以运行,少包了一个OSG库,呵呵,GDAL要用gdal_i.lib

该用户从未签到

发表于 2013-2-26 20:25:39 | 显示全部楼层
我想说的是,19楼SB么

该用户从未签到

发表于 2013-3-6 11:02:03 | 显示全部楼层
能否提供下案例的源码呢

该用户从未签到

发表于 2013-3-10 16:18:53 | 显示全部楼层
太感谢楼主了

该用户从未签到

发表于 2013-3-14 17:11:44 | 显示全部楼层
谢谢楼主分享!

该用户从未签到

发表于 2013-3-20 08:48:06 | 显示全部楼层
很好! 支持!

该用户从未签到

发表于 2013-5-7 17:20:40 | 显示全部楼层
楼主 找不到OSGQtd.lib  需要在源码里另行编译吗?

该用户从未签到

 楼主| 发表于 2013-5-7 22:10:46 | 显示全部楼层
Pricas 发表于 2013-5-7 17:20
楼主 找不到OSGQtd.lib  需要在源码里另行编译吗?

osgQt库简单,不需编译,使用时把相关代码拷贝过来即可,避免大家使用时出现Qt版本不一致,容易出问题

该用户从未签到

发表于 2013-5-8 00:31:49 | 显示全部楼层
ago 发表于 2013-5-7 22:10
osgQt库简单,不需编译,使用时把相关代码拷贝过来即可,避免大家使用时出现Qt版本不一致,容易出问题

我这现在已有一个工程 用的是旧版的osg和osgEarth  里面用到了osgQtd.lib

刚试着替换成您所提供的新版本的库

编译时工程提示缺少osgQtd.lib  请问该如何解决这个问题。。

该用户从未签到

 楼主| 发表于 2013-5-9 20:50:28 | 显示全部楼层

OSG3.01+osgEarth2.2

本帖最后由 ago 于 2013-5-9 20:56 编辑
Pricas 发表于 2013-5-8 00:31
我这现在已有一个工程 用的是旧版的osg和osgEarth  里面用到了osgQtd.lib

刚试着替换成您所提供的新版 ...


   百度网盘(OSG3.01+osgEarth2.2):http://pan.baidu.com/share/link?shareid=389389&uk=2801833827
   115网盘(OSG3.01+osgEarth2.2):http://115.com/file/an01d9l4

这是我之前编译的一个老版,带有osgQt库,qt用的是4.8.0,不同版本的最好不要混合使用

该用户从未签到

发表于 2013-6-20 16:20:32 | 显示全部楼层
楼主太给力了!!
您需要登录后才可以回帖 登录 | 注册

本版积分规则

OSG中国官方论坛-有您OSG在中国才更好

网站简介:osgChina是国内首个三维相关技术开源社区,旨在为国内更多的技术开发人员提供最前沿的技术资讯,为更多的三维从业者提供一个学习、交流的技术平台。

联系我们

  • 工作时间:09:00--18:00
  • 反馈邮箱:1315785073@qq.com
快速回复 返回顶部 返回列表